Skip to content
Snippets Groups Projects
Commit 3cdc24e6 authored by fischertechnik-opensource's avatar fischertechnik-opensource
Browse files

Update to 3.1.5

parent 9eea713e
Branches 3.1.5
No related tags found
No related merge requests found
Showing
with 477 additions and 29 deletions
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
update_config=1
# generate credential with: wpa_passphrase YOUR_SSID >> THIS_FILE
#network={
# ssid="YOUR_SSID"
# psk=YOUR_KEY
#}
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://wpa_supplicant-mlan0.conf"
SRC_URI += "file://wpa_supplicant-mlan0.conf \
file://wpa_supplicant-wlan0.conf \
"
do_install_append() {
install -d ${D}${sysconfdir}
install -d ${D}${sysconfdir}/wpa_supplicant
install -m 600 ${WORKDIR}/wpa_supplicant-mlan0.conf ${D}${sysconfdir}/wpa_supplicant
install -m 600 ${WORKDIR}/wpa_supplicant-wlan0.conf ${D}${sysconfdir}/wpa_supplicant
}
#!/bin/sh
cd patches
startwith=49
endwith=288
i=$startwith
count=1000
echo PATCHLIST = \"\\ > ../kernelpatches.bbappend
while([ "$i" -lt "$((endwith))" ])
do
echo $i-$((i + 1))
curl https://cdn.kernel.org/pub/linux/kernel/v4.x/incr/patch-4.19.$i-$((i + 1)).xz -o patch-4.19.$i-$((i + 1)).xz
xz -d -v patch-4.19.$i-$((i + 1)).xz
mv patch-4.19.$i-$((i + 1)) ${count}-patch-4.19.$i-$((i + 1)).patch
echo " file://patches/${count}-patch-4.19.$i-$((i + 1)).patch \\" >> ../kernelpatches.bbappend
i=$((i+1))
count=$((count+1))
done
echo " \"" >> ../kernelpatches.bbappend
#https://cdn.kernel.org/pub/linux/kernel/v4.x/incr/patch-4.19.49-50.xz
PATCHLIST = "\
file://patches/1000-patch-4.19.49-50.patch \
file://patches/1001-patch-4.19.50-51.patch \
file://patches/1002-patch-4.19.51-52.patch \
file://patches/1003-patch-4.19.52-53.patch \
file://patches/1004-patch-4.19.53-54.patch \
file://patches/1005-patch-4.19.54-55.patch \
file://patches/1006-patch-4.19.55-56.patch \
file://patches/1007-patch-4.19.56-57.patch \
file://patches/1008-patch-4.19.57-58.patch \
file://patches/1009-patch-4.19.58-59.patch \
file://patches/1010-patch-4.19.59-60.patch \
file://patches/1011-patch-4.19.60-61.patch \
file://patches/1012-patch-4.19.61-62.patch \
file://patches/1013-patch-4.19.62-63.patch \
file://patches/1014-patch-4.19.63-64.patch \
file://patches/1015-patch-4.19.64-65.patch \
file://patches/1016-patch-4.19.65-66.patch \
file://patches/1017-patch-4.19.66-67.patch \
file://patches/1018-patch-4.19.67-68.patch \
file://patches/1019-patch-4.19.68-69.patch \
file://patches/1020-patch-4.19.69-70.patch \
file://patches/1021-patch-4.19.70-71.patch \
file://patches/1022-patch-4.19.71-72.patch \
file://patches/1023-patch-4.19.72-73.patch \
file://patches/1024-patch-4.19.73-74.patch \
file://patches/1025-patch-4.19.74-75.patch \
file://patches/1026-patch-4.19.75-76.patch \
file://patches/1027-patch-4.19.76-77.patch \
file://patches/1028-patch-4.19.77-78.patch \
file://patches/1029-patch-4.19.78-79.patch \
file://patches/1030-patch-4.19.79-80.patch \
file://patches/1031-patch-4.19.80-81.patch \
file://patches/1032-patch-4.19.81-82.patch \
file://patches/1033-patch-4.19.82-83.patch \
file://patches/1034-patch-4.19.83-84.patch \
file://patches/1035-patch-4.19.84-85.patch \
file://patches/1036-patch-4.19.85-86.patch \
file://patches/1037-patch-4.19.86-87.patch \
file://patches/1038-patch-4.19.87-88.patch \
file://patches/1039-patch-4.19.88-89.patch \
file://patches/1040-patch-4.19.89-90.patch \
file://patches/1041-patch-4.19.90-91.patch \
file://patches/1042-patch-4.19.91-92.patch \
file://patches/1043-patch-4.19.92-93.patch \
file://patches/1044-patch-4.19.93-94.patch \
file://patches/1045-patch-4.19.94-95.patch \
file://patches/1046-patch-4.19.95-96.patch \
file://patches/1047-patch-4.19.96-97.patch \
file://patches/1048-patch-4.19.97-98.patch \
file://patches/1049-patch-4.19.98-99.patch \
file://patches/1050-patch-4.19.99-100.patch \
file://patches/1051-patch-4.19.100-101.patch \
file://patches/1052-patch-4.19.101-102.patch \
file://patches/1053-patch-4.19.102-103.patch \
file://patches/1054-patch-4.19.103-104.patch \
file://patches/1055-patch-4.19.104-105.patch \
file://patches/1056-patch-4.19.105-106.patch \
file://patches/1057-patch-4.19.106-107.patch \
file://patches/1058-patch-4.19.107-108.patch \
file://patches/1059-patch-4.19.108-109.patch \
file://patches/1060-patch-4.19.109-110.patch \
file://patches/1061-patch-4.19.110-111.patch \
file://patches/1062-patch-4.19.111-112.patch \
file://patches/1063-patch-4.19.112-113.patch \
file://patches/1064-patch-4.19.113-114.patch \
file://patches/1065-patch-4.19.114-115.patch \
file://patches/1066-patch-4.19.115-116.patch \
file://patches/1067-patch-4.19.116-117.patch \
file://patches/1068-patch-4.19.117-118.patch \
file://patches/1069-patch-4.19.118-119.patch \
file://patches/1070-patch-4.19.119-120.patch \
file://patches/1071-patch-4.19.120-121.patch \
file://patches/1072-patch-4.19.121-122.patch \
file://patches/1073-patch-4.19.122-123.patch \
file://patches/1074-patch-4.19.123-124.patch \
file://patches/1075-patch-4.19.124-125.patch \
file://patches/1076-patch-4.19.125-126.patch \
file://patches/1077-patch-4.19.126-127.patch \
file://patches/1078-patch-4.19.127-128.patch \
file://patches/1079-patch-4.19.128-129.patch \
file://patches/1080-patch-4.19.129-130.patch \
file://patches/1081-patch-4.19.130-131.patch \
file://patches/1082-patch-4.19.131-132.patch \
file://patches/1083-patch-4.19.132-133.patch \
file://patches/1084-patch-4.19.133-134.patch \
file://patches/1085-patch-4.19.134-135.patch \
file://patches/1086-patch-4.19.135-136.patch \
file://patches/1087-patch-4.19.136-137.patch \
file://patches/1088-patch-4.19.137-138.patch \
file://patches/1089-patch-4.19.138-139.patch \
file://patches/1090-patch-4.19.139-140.patch \
file://patches/1091-patch-4.19.140-141.patch \
file://patches/1092-patch-4.19.141-142.patch \
file://patches/1093-patch-4.19.142-143.patch \
file://patches/1094-patch-4.19.143-144.patch \
file://patches/1095-patch-4.19.144-145.patch \
file://patches/1096-patch-4.19.145-146.patch \
file://patches/1097-patch-4.19.146-147.patch \
file://patches/1098-patch-4.19.147-148.patch \
file://patches/1099-patch-4.19.148-149.patch \
file://patches/1100-patch-4.19.149-150.patch \
file://patches/1101-patch-4.19.150-151.patch \
file://patches/1102-patch-4.19.151-152.patch \
file://patches/1103-patch-4.19.152-153.patch \
file://patches/1104-patch-4.19.153-154.patch \
file://patches/1105-patch-4.19.154-155.patch \
file://patches/1106-patch-4.19.155-156.patch \
file://patches/1107-patch-4.19.156-157.patch \
file://patches/1108-patch-4.19.157-158.patch \
file://patches/1109-patch-4.19.158-159.patch \
file://patches/1110-patch-4.19.159-160.patch \
file://patches/1111-patch-4.19.160-161.patch \
file://patches/1112-patch-4.19.161-162.patch \
file://patches/1113-patch-4.19.162-163.patch \
file://patches/1114-patch-4.19.163-164.patch \
file://patches/1115-patch-4.19.164-165.patch \
file://patches/1116-patch-4.19.165-166.patch \
file://patches/1117-patch-4.19.166-167.patch \
file://patches/1118-patch-4.19.167-168.patch \
file://patches/1119-patch-4.19.168-169.patch \
file://patches/1120-patch-4.19.169-170.patch \
file://patches/1121-patch-4.19.170-171.patch \
file://patches/1122-patch-4.19.171-172.patch \
file://patches/1123-patch-4.19.172-173.patch \
file://patches/1124-patch-4.19.173-174.patch \
file://patches/1125-patch-4.19.174-175.patch \
file://patches/1126-patch-4.19.175-176.patch \
file://patches/1127-patch-4.19.176-177.patch \
file://patches/1128-patch-4.19.177-178.patch \
file://patches/1129-patch-4.19.178-179.patch \
file://patches/1130-patch-4.19.179-180.patch \
file://patches/1131-patch-4.19.180-181.patch \
file://patches/1132-patch-4.19.181-182.patch \
file://patches/1133-patch-4.19.182-183.patch \
file://patches/1134-patch-4.19.183-184.patch \
file://patches/1135-patch-4.19.184-185.patch \
file://patches/1136-patch-4.19.185-186.patch \
file://patches/1137-patch-4.19.186-187.patch \
file://patches/1138-patch-4.19.187-188.patch \
file://patches/1139-patch-4.19.188-189.patch \
file://patches/1140-patch-4.19.189-190.patch \
file://patches/1141-patch-4.19.190-191.patch \
file://patches/1142-patch-4.19.191-192.patch \
file://patches/1143-patch-4.19.192-193.patch \
file://patches/1144-patch-4.19.193-194.patch \
file://patches/1145-patch-4.19.194-195.patch \
file://patches/1146-patch-4.19.195-196.patch \
file://patches/1147-patch-4.19.196-197.patch \
file://patches/1148-patch-4.19.197-198.patch \
file://patches/1149-patch-4.19.198-199.patch \
file://patches/1150-patch-4.19.199-200.patch \
file://patches/1151-patch-4.19.200-201.patch \
file://patches/1152-patch-4.19.201-202.patch \
file://patches/1153-patch-4.19.202-203.patch \
file://patches/1154-patch-4.19.203-204.patch \
file://patches/1155-patch-4.19.204-205.patch \
file://patches/1156-patch-4.19.205-206.patch \
file://patches/1157-patch-4.19.206-207.patch \
file://patches/1158-patch-4.19.207-208.patch \
file://patches/1159-patch-4.19.208-209.patch \
file://patches/1160-patch-4.19.209-210.patch \
file://patches/1161-patch-4.19.210-211.patch \
file://patches/1162-patch-4.19.211-212.patch \
file://patches/1163-patch-4.19.212-213.patch \
file://patches/1164-patch-4.19.213-214.patch \
file://patches/1165-patch-4.19.214-215.patch \
file://patches/1166-patch-4.19.215-216.patch \
file://patches/1167-patch-4.19.216-217.patch \
file://patches/1168-patch-4.19.217-218.patch \
file://patches/1169-patch-4.19.218-219.patch \
file://patches/1170-patch-4.19.219-220.patch \
file://patches/1171-patch-4.19.220-221.patch \
file://patches/1172-patch-4.19.221-222.patch \
file://patches/1173-patch-4.19.222-223.patch \
file://patches/1174-patch-4.19.223-224.patch \
file://patches/1175-patch-4.19.224-225.patch \
file://patches/1176-patch-4.19.225-226.patch \
file://patches/1177-patch-4.19.226-227.patch \
file://patches/1178-patch-4.19.227-228.patch \
file://patches/1179-patch-4.19.228-229.patch \
file://patches/1180-patch-4.19.229-230.patch \
file://patches/1181-patch-4.19.230-231.patch \
file://patches/1182-patch-4.19.231-232.patch \
file://patches/1183-patch-4.19.232-233.patch \
file://patches/1184-patch-4.19.233-234.patch \
file://patches/1185-patch-4.19.234-235.patch \
file://patches/1186-patch-4.19.235-236.patch \
file://patches/1187-patch-4.19.236-237.patch \
file://patches/1188-patch-4.19.237-238.patch \
file://patches/1189-patch-4.19.238-239.patch \
file://patches/1190-patch-4.19.239-240.patch \
file://patches/1191-patch-4.19.240-241.patch \
file://patches/1192-patch-4.19.241-242.patch \
file://patches/1193-patch-4.19.242-243.patch \
file://patches/1194-patch-4.19.243-244.patch \
file://patches/1195-patch-4.19.244-245.patch \
file://patches/1196-patch-4.19.245-246.patch \
file://patches/1197-patch-4.19.246-247.patch \
file://patches/1198-patch-4.19.247-248.patch \
file://patches/1199-patch-4.19.248-249.patch \
file://patches/1200-patch-4.19.249-250.patch \
file://patches/1201-patch-4.19.250-251.patch \
file://patches/1202-patch-4.19.251-252.patch \
file://patches/1203-patch-4.19.252-253.patch \
file://patches/1204-patch-4.19.253-254.patch \
file://patches/1205-patch-4.19.254-255.patch \
file://patches/1206-patch-4.19.255-256.patch \
file://patches/1207-patch-4.19.256-257.patch \
file://patches/1208-patch-4.19.257-258.patch \
file://patches/1209-patch-4.19.258-259.patch \
file://patches/1210-patch-4.19.259-260.patch \
file://patches/1211-patch-4.19.260-261.patch \
file://patches/1212-patch-4.19.261-262.patch \
file://patches/1213-patch-4.19.262-263.patch \
file://patches/1214-patch-4.19.263-264.patch \
file://patches/1215-patch-4.19.264-265.patch \
file://patches/1216-patch-4.19.265-266.patch \
file://patches/1217-patch-4.19.266-267.patch \
file://patches/1218-patch-4.19.267-268.patch \
file://patches/1219-patch-4.19.268-269.patch \
file://patches/1220-patch-4.19.269-270.patch \
file://patches/1221-patch-4.19.270-271.patch \
file://patches/1222-patch-4.19.271-272.patch \
file://patches/1223-patch-4.19.272-273.patch \
file://patches/1224-patch-4.19.273-274.patch \
file://patches/1225-patch-4.19.274-275.patch \
file://patches/1226-patch-4.19.275-276.patch \
file://patches/1227-patch-4.19.276-277.patch \
file://patches/1228-patch-4.19.277-278.patch \
file://patches/1229-patch-4.19.278-279.patch \
file://patches/1230-patch-4.19.279-280.patch \
file://patches/1231-patch-4.19.280-281.patch \
file://patches/1232-patch-4.19.281-282.patch \
file://patches/1233-patch-4.19.282-283.patch \
file://patches/1234-patch-4.19.283-284.patch \
file://patches/1235-patch-4.19.284-285.patch \
file://patches/1236-patch-4.19.285-286.patch \
file://patches/1237-patch-4.19.286-287.patch \
file://patches/1238-patch-4.19.287-288.patch \
"
......@@ -137,21 +137,6 @@ index 85c2d407a52e..9e13e466e72c 100644
{
unsigned int low_refresh_rate;
unsigned int hsync_polarity = 0;
@@ -747,11 +747,11 @@ static void adv7511_mode_set(struct adv7511 *adv7511,
vsync_polarity = 1;
}
- if (mode->vrefresh <= 24000)
+ if (drm_mode_vrefresh(mode) <= 24)
low_refresh_rate = ADV7511_LOW_REFRESH_RATE_24HZ;
- else if (mode->vrefresh <= 25000)
+ else if (drm_mode_vrefresh(mode) <= 25)
low_refresh_rate = ADV7511_LOW_REFRESH_RATE_25HZ;
- else if (mode->vrefresh <= 30000)
+ else if (drm_mode_vrefresh(mode) <= 30)
low_refresh_rate = ADV7511_LOW_REFRESH_RATE_30HZ;
else
low_refresh_rate = ADV7511_LOW_REFRESH_RATE_NONE;
@@ -839,8 +839,8 @@ static void adv7511_bridge_disable(struct drm_bridge *bridge)
}
......
From: Manuel Schreiner, manuel.schreiner@accso.de
Date: Wed, 26th July 2023
Subject: [PATCH] add missing drm_probe_helper.h
---
include/drm/drm_probe_helper.h | 27 ++++++++++++++++++++
1 files changed, 27 insertions(+)
create mode 100644 include/drm/drm_probe_helper.h
diff --git a/include/drm/drm_probe_helper.h b/include/drm/drm_probe_helper.h
new file mode 100644
index 000000000000..8d3ed2834d34
--- /dev/null
+++ b/include/drm/drm_probe_helper.h
@@ -0,0 +1,27 @@
+// SPDX-License-Identifier: GPL-2.0 OR MIT
+
+#ifndef __DRM_PROBE_HELPER_H__
+#define __DRM_PROBE_HELPER_H__
+
+#include <linux/types.h>
+
+struct drm_connector;
+struct drm_device;
+struct drm_modeset_acquire_ctx;
+
+int drm_helper_probe_single_connector_modes(struct drm_connector
+ *connector, uint32_t maxX,
+ uint32_t maxY);
+int drm_helper_probe_detect(struct drm_connector *connector,
+ struct drm_modeset_acquire_ctx *ctx,
+ bool force);
+void drm_kms_helper_poll_init(struct drm_device *dev);
+void drm_kms_helper_poll_fini(struct drm_device *dev);
+bool drm_helper_hpd_irq_event(struct drm_device *dev);
+void drm_kms_helper_hotplug_event(struct drm_device *dev);
+
+void drm_kms_helper_poll_disable(struct drm_device *dev);
+void drm_kms_helper_poll_enable(struct drm_device *dev);
+bool drm_kms_helper_is_poll_worker(void);
+
+#endif
patches=$(ls 10*-*.patch)
counter=1
for patch in $patches
do
mv $patch 0001-$patch
done
patches=$(ls 11*-*.patch)
counter=1
for patch in $patches
do
mv $patch 0001-$patch
done
patches=$(ls 12*-*.patch)
counter=1
for patch in $patches
do
mv $patch 0001-$patch
done
......@@ -5,6 +5,10 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
# Version r2.0
####################################################################################
# 4.19.49 / r2.0: 9cc80ff80f5ea5f1ff35122f61afaa7b11ad22ae -->meta-st-stm32mp: rev=cc8dcc21ee8304bfafc02e86e60d7efbf6ad2dbd
# 4.19.93 / r3.0: 1cb30cb5ffc29a53ec2031b6a29878ddd266516c --> meta-st-stm32mp: rev=96ba7e130e79bbb0e2db434495acc56641963013
# 4.19.143 / r3.3: 24e698236f9c2197f9e4547075ec9647e8b99814 --> meta-st-stm32mp: rev=d8cbac759e1275b1a27d4ba38b64a0d83d0e8c9f
SRCREV = "9cc80ff80f5ea5f1ff35122f61afaa7b11ad22ae"
SRCREV_bleeding = "${AUTOREV}"
SRC_URI="git://github.com/STMicroelectronics/linux.git;protocol=https;branch=v${LINUX_VERSION}-stm32mp;name=linux"
......@@ -17,10 +21,12 @@ S = "${WORKDIR}/${SUBDIR_DIR}"
####################################################################################
# Fixes
# Kernel 4.19.49
PATCHLIST = "\
file://patches/0100-STMFIX-regulator-stm32-vrefbuf-fix-a-possible-overshoot-whe.patch \
file://patches/0101-fix-missing-eth-phy-clocks.patch \
file://patches/0102-spi-nand-fix-QSPI-NAND-bad-block-marking-issue.patch \
file://patches/0400-STMFIX-regulator-stm32-vrefbuf-fix-a-possible-overshoot-whe.patch \
file://patches/0401-fix-missing-eth-phy-clocks.patch \
file://patches/0402-spi-nand-fix-QSPI-NAND-bad-block-marking-issue.patch \
"
# Features
PATCHLIST += "\
......@@ -38,20 +44,76 @@ PATCHLIST += "\
file://patches/0511-dt-bindings-drm-bridge-adv7511-Add-ADV7535-support.patch \
file://patches/0512-drm-bridge-adv7511-Add-support-for-ADV7535.patch \
file://patches/0513-adapt-kernel-interfaces.patch \
file://patches/0001-stm-drm-driver-fetch-newest-source-code-from-st-repo.patch \
file://patches/0002-synopsys-dsi-driver-fetch-newest-source-code-from-st.patch \
file://patches/0003-drm-bridge-synopsys-dsi-fix-activation-sequence.patch \
file://patches/0004-drm-bridge-synopsys-dsi-cleanup-when-probe-fails.patch \
file://patches/0005-drm-bridge-synposys-dsi-fix-oops-in-drm-post_disable.patch \
file://patches/0006-drm_modes-suppress-error-for-hsync-vsync-flag.patch \
file://patches/0001-drm-stm-dsi-higher-pll-out-only-in-video-burst-mode.patch \
file://patches/0001-Add-mcp25xxfd-SPI-CANFD-driver.patch \
file://patches/0301-stm-drm-driver-fetch-newest-source-code-from-st-repo.patch \
file://patches/0302-synopsys-dsi-driver-fetch-newest-source-code-from-st.patch \
file://patches/0303-drm-bridge-synopsys-dsi-fix-activation-sequence.patch \
file://patches/0304-drm-bridge-synopsys-dsi-cleanup-when-probe-fails.patch \
file://patches/0305-drm-bridge-synposys-dsi-fix-oops-in-drm-post_disable.patch \
file://patches/0306-drm_modes-suppress-error-for-hsync-vsync-flag.patch \
file://patches/0301-drm-stm-dsi-higher-pll-out-only-in-video-burst-mode.patch \
file://patches/0301-Add-mcp25xxfd-SPI-CANFD-driver.patch \
"
# Kernel 4.19.94
#PATCHLIST = "\
# file://patches/0401-fix-missing-eth-phy-clocks.patch \
# file://patches/0402-spi-nand-fix-QSPI-NAND-bad-block-marking-issue.patch \
# "
## Features
#PATCHLIST += "\
# file://patches/0500-linux-stm32mp-disable-spidev-warning-message.patch \
# file://patches/0501-add-SPI-NOR-mx25r1635f.patch \
# file://patches/0502-mtd-spi-nor-Add-support-for-Macronix-MX25V8035F.patch \
# file://patches/0503-drm-panel-simple-Add-support-for-Admatec-T043C004800.patch \
# file://patches/0504-drm-panel-simple-Add-support-for-Admatec-T070P133T0S.patch \
# file://patches/0505-mtd-nand-spi-Add-initial-support-for-Toshiba-TC58CVG.patch \
# file://patches/0506-sn65dsi83-Add-ti-sn85dsi83-dsi-to-lvds-bridge-driver.patch \
# file://patches/0507-wm8510-switch-to-mclk-on-hw-init.patch \
# file://patches/0508-add-spi-clock-debug-print.patch \
# file://patches/0509-pinctl-disable-strict-checking.patch \
# file://patches/0510-adv7511-mainline-5.4.x-code-integrated.patch \
# file://patches/0511-dt-bindings-drm-bridge-adv7511-Add-ADV7535-support.patch \
# file://patches/0512-drm-bridge-adv7511-Add-support-for-ADV7535.patch \
# file://patches/0513-adapt-kernel-interfaces.patch \
# file://patches/0303-drm-bridge-synopsys-dsi-fix-activation-sequence.patch \
# file://patches/0304-drm-bridge-synopsys-dsi-cleanup-when-probe-fails.patch \
# file://patches/0305-drm-bridge-synposys-dsi-fix-oops-in-drm-post_disable.patch \
# file://patches/0306-drm_modes-suppress-error-for-hsync-vsync-flag.patch \
# file://patches/0301-drm-stm-dsi-higher-pll-out-only-in-video-burst-mode.patch \
# file://patches/0301-Add-mcp25xxfd-SPI-CANFD-driver.patch \
# "
# Kernel 4.19.143
#PATCHLIST = "\
# file://patches/0401-fix-missing-eth-phy-clocks.patch \
# "
## Features
#PATCHLIST += "\
# file://patches/0500-linux-stm32mp-disable-spidev-warning-message.patch \
# file://patches/0501-add-SPI-NOR-mx25r1635f.patch \
# file://patches/0502-mtd-spi-nor-Add-support-for-Macronix-MX25V8035F.patch \
# file://patches/0503-drm-panel-simple-Add-support-for-Admatec-T043C004800.patch \
# file://patches/0504-drm-panel-simple-Add-support-for-Admatec-T070P133T0S.patch \
# file://patches/0505-mtd-nand-spi-Add-initial-support-for-Toshiba-TC58CVG.patch \
# file://patches/0507-wm8510-switch-to-mclk-on-hw-init.patch \
# file://patches/0508-add-spi-clock-debug-print.patch \
# file://patches/0509-pinctl-disable-strict-checking.patch \
# file://patches/0510-adv7511-mainline-5.4.x-code-integrated.patch \
# file://patches/0511-dt-bindings-drm-bridge-adv7511-Add-ADV7535-support.patch \
# file://patches/0512-drm-bridge-adv7511-Add-support-for-ADV7535.patch \
# file://patches/0513-adapt-kernel-interfaces.patch \
# file://patches/0303-drm-bridge-synopsys-dsi-fix-activation-sequence.patch \
# file://patches/0304-drm-bridge-synopsys-dsi-cleanup-when-probe-fails.patch \
# file://patches/0305-drm-bridge-synposys-dsi-fix-oops-in-drm-post_disable.patch \
# file://patches/0306-drm_modes-suppress-error-for-hsync-vsync-flag.patch \
# file://patches/0301-drm-stm-dsi-higher-pll-out-only-in-video-burst-mode.patch \
# "
# Fixes
PATCHLIST_bleeding = "\
file://patches/0101-fix-missing-eth-phy-clocks.patch \
file://patches/0102-spi-nand-fix-QSPI-NAND-bad-block-marking-issue.patch \
file://patches/0401-fix-missing-eth-phy-clocks.patch \
file://patches/0402-spi-nand-fix-QSPI-NAND-bad-block-marking-issue.patch \
"
PATCHLIST_bleeding += "\
file://patches/0500-linux-stm32mp-disable-spidev-warning-message.patch \
......@@ -70,6 +132,72 @@ PATCHLIST_bleeding += "\
file://patches/0513-adapt-kernel-interfaces.patch \
"
#
# file://${LINUX_VERSION}/4.19.94/0001-ARM-stm32mp1-r3-MACHINE.patch \
# file://${LINUX_VERSION}/4.19.94/0002-ARM-stm32mp1-r3-CPUFREQ.patch \
# file://${LINUX_VERSION}/4.19.94/0003-ARM-stm32mp1-r3-CRYPTO.patch \
# file://${LINUX_VERSION}/4.19.94/0004-ARM-stm32mp1-r3-BLUETOOTH-CHAR.patch \
# file://${LINUX_VERSION}/4.19.94/0005-ARM-stm32mp1-r3-CLOCK.patch \
# file://${LINUX_VERSION}/4.19.94/0006-ARM-stm32mp1-r3-DMA.patch \
# file://${LINUX_VERSION}/4.19.94/0007-ARM-stm32mp1-r3-DRM.patch \
# file://${LINUX_VERSION}/4.19.94/0008-ARM-stm32mp1-r3-GPIO.patch \
# file://${LINUX_VERSION}/4.19.94/0009-ARM-stm32mp1-r3-HWSPINLOCK.patch \
# file://${LINUX_VERSION}/4.19.94/0010-ARM-stm32mp1-r3-HWTRACING-I2C.patch \
# file://${LINUX_VERSION}/4.19.94/0011-ARM-stm32mp1-r3-IIO.patch \
# file://${LINUX_VERSION}/4.19.94/0012-ARM-stm32mp1-r3-INPUT-IRQ-Mailbox.patch \
# file://${LINUX_VERSION}/4.19.94/0013-ARM-stm32mp1-r3-MEDIA.patch \
# file://${LINUX_VERSION}/4.19.94/0014-ARM-stm32mp1-r3-MFD.patch \
# file://${LINUX_VERSION}/4.19.94/0015-ARM-stm32mp1-r3-MMC-MTD.patch \
# file://${LINUX_VERSION}/4.19.94/0016-ARM-stm32mp1-r3-NET.patch \
# file://${LINUX_VERSION}/4.19.94/0017-ARM-stm32mp1-r3-NVMEM.patch \
# file://${LINUX_VERSION}/4.19.94/0018-ARM-stm32mp1-r3-PERF.patch \
# file://${LINUX_VERSION}/4.19.94/0019-ARM-stm32mp1-r3-PHY-PINCTRL-PWM.patch \
# file://${LINUX_VERSION}/4.19.94/0020-ARM-stm32mp1-r3-REGULATOR.patch \
# file://${LINUX_VERSION}/4.19.94/0021-ARM-stm32mp1-r3-REMOTEPROC-RPMSG-RESET.patch \
# file://${LINUX_VERSION}/4.19.94/0022-ARM-stm32mp1-r3-RTC.patch \
# file://${LINUX_VERSION}/4.19.94/0023-ARM-stm32mp1-r3-SOC.patch \
# file://${LINUX_VERSION}/4.19.94/0024-ARM-stm32mp1-r3-SPI.patch \
# file://${LINUX_VERSION}/4.19.94/0025-ARM-stm32mp1-r3-THERMAL.patch \
# file://${LINUX_VERSION}/4.19.94/0027-ARM-stm32mp1-r3-WATCHDOG.patch \
# file://${LINUX_VERSION}/4.19.94/0028-ARM-stm32mp1-r3-SOUND.patch \
# file://${LINUX_VERSION}/4.19.94/0030-ARM-stm32mp1-r3-DEVICETREE.patch \
# file://${LINUX_VERSION}/4.19.94/0026-ARM-stm32mp1-r3-TTY-USB.patch \
# file://${LINUX_VERSION}/4.19.94/0029-ARM-stm32mp1-r3-MISC.patch \
#
#SRC_URI_append += "\
# file://${LINUX_VERSION}/4.19.94/0001-ARM-stm32mp1-r3-MACHINE.patch \
# file://${LINUX_VERSION}/4.19.94/0002-ARM-stm32mp1-r3-CPUFREQ.patch \
# file://${LINUX_VERSION}/4.19.94/0003-ARM-stm32mp1-r3-CRYPTO.patch \
# file://${LINUX_VERSION}/4.19.94/0004-ARM-stm32mp1-r3-BLUETOOTH-CHAR.patch \
# file://${LINUX_VERSION}/4.19.94/0005-ARM-stm32mp1-r3-CLOCK.patch \
# file://${LINUX_VERSION}/4.19.94/0006-ARM-stm32mp1-r3-DMA.patch \
# file://${LINUX_VERSION}/4.19.94/0007-ARM-stm32mp1-r3-DRM.patch \
# file://${LINUX_VERSION}/4.19.94/0008-ARM-stm32mp1-r3-GPIO.patch \
# file://${LINUX_VERSION}/4.19.94/0009-ARM-stm32mp1-r3-HWSPINLOCK.patch \
# file://${LINUX_VERSION}/4.19.94/0010-ARM-stm32mp1-r3-HWTRACING-I2C.patch \
# file://${LINUX_VERSION}/4.19.94/0011-ARM-stm32mp1-r3-IIO.patch \
# file://${LINUX_VERSION}/4.19.94/0012-ARM-stm32mp1-r3-INPUT-IRQ-Mailbox.patch \
# file://${LINUX_VERSION}/4.19.94/0013-ARM-stm32mp1-r3-MEDIA.patch \
# file://${LINUX_VERSION}/4.19.94/0014-ARM-stm32mp1-r3-MFD.patch \
# file://${LINUX_VERSION}/4.19.94/0015-ARM-stm32mp1-r3-MMC-MTD.patch \
# file://${LINUX_VERSION}/4.19.94/0016-ARM-stm32mp1-r3-NET.patch \
# file://${LINUX_VERSION}/4.19.94/0017-ARM-stm32mp1-r3-NVMEM.patch \
# file://${LINUX_VERSION}/4.19.94/0018-ARM-stm32mp1-r3-PERF.patch \
# file://${LINUX_VERSION}/4.19.94/0019-ARM-stm32mp1-r3-PHY-PINCTRL-PWM.patch \
# file://${LINUX_VERSION}/4.19.94/0020-ARM-stm32mp1-r3-REGULATOR.patch \
# file://${LINUX_VERSION}/4.19.94/0021-ARM-stm32mp1-r3-REMOTEPROC-RPMSG-RESET.patch \
# file://${LINUX_VERSION}/4.19.94/0022-ARM-stm32mp1-r3-RTC.patch \
# file://${LINUX_VERSION}/4.19.94/0023-ARM-stm32mp1-r3-SOC.patch \
# file://${LINUX_VERSION}/4.19.94/0024-ARM-stm32mp1-r3-SPI.patch \
# file://${LINUX_VERSION}/4.19.94/0025-ARM-stm32mp1-r3-THERMAL.patch \
# file://${LINUX_VERSION}/4.19.94/0027-ARM-stm32mp1-r3-WATCHDOG.patch \
# file://${LINUX_VERSION}/4.19.94/0028-ARM-stm32mp1-r3-SOUND.patch \
# file://${LINUX_VERSION}/4.19.94/0030-ARM-stm32mp1-r3-DEVICETREE.patch \
# file://${LINUX_VERSION}/4.19.94/0026-ARM-stm32mp1-r3-TTY-USB.patch \
# file://${LINUX_VERSION}/4.19.94/0029-ARM-stm32mp1-r3-MISC.patch \
# "
# common patches
SRC_URI_append += "${PATCHLIST}"
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment